Total_Noob氏の2.05kxploit 2.06で対策された?





Total_Noob氏は実は2.05向けのカーネルexploit(kxploit)を所有しています。したがってリリースされていないだけで物理的には2.05での6.60 TN-Vは不可能ではありません。

将来公開されるかもしれないkxploitに備えて2.02 UNO exploitでTN-Vを使い、kxploitが公開されたらアップデートしようと考えていた方には今回の話は残念なお知らせになるかもしれません。

現時点ではリリース予定はないもののTotal_Noob氏は2.05でも有効なカーネルexploit(kxploit)を持っていることは明らかになっています。未公開kxploitが故に情報がないため正確な情報は分かりませんが、Total_Noob氏とコンタクトを取っているThe Z氏は以下のような気になる発言をしていました。

Vitaが2.05以下でexploitなゲームを持っているなら、絶対に2.06へはアップデートしないでください。2.05以下のexploitなゲームならTN-Vいけるけど2.06じゃ動かない。

2.05で多数のkxploitが対策された中でも残存していたkxploitが、2.06では対策されてしまったことを意味していると思われます。

昨日公開されたTomTomDu80氏のApache Overkill VHBLは、元々2.05で動くバージョンとしてその存在が公表され、ゲーム名公開前にリリースされた2.06でも動いたことから2.06向けとしてリリースされました。そのため残念ながら2.05向けのセーブデータexploitのあるゲームは一切一般公開されていません。更には既にPS Vitaは2.06が最新システムバージョンであるため、今すぐ新たにゲーム名を公開したところで2.05の状態ではPSストアでゲームを購入できません。まもなくApache Overkill exploit対策のファームウェア 2.07あたりも公開されるでしょう。

つまり、2.06で既知のkxploitが全て対策されてしまった時点でもう手遅れだったのです。

もっとも、既知のkxploitはTotal_Noob氏の一つだけではありませんが、TN-V開発者の元へその他のkxploitの情報が集まってくるのは自然な流れですし、それを踏まえてTotal_Noob氏がThe Z氏に伝えたのだとすると(あるいはThe Z氏も情報を共有している可能性があります)、最悪は現時点でkxploit全滅ということも十分あり得ます。

ちなみに、私の推測は「Total_Noob氏がThe Z氏と情報を共有しているのだとすると」という部分だけで、それが正しいとするならば今回のThe Z氏の発言と私が聞いている情報と整合すると現時点ではkxploit全滅です。

Tags: , , , , ,

  1. mayataka’s avatar

    個人的には春休み商戦に合わせて発売されたタイトルも多いので、既に公式からの対策済みkexploitとバージョン2.05タイトルのリリースはしてもらえるとありがたいですね。
    結局それが後のkexploitの残存数に関わらないわけですし、できれば欲しい、というのが本音です。

  2. kaks’s avatar

    情報遅すぎ。
    いつも新FWが公開された後すぐ情報が来るのに、なんで今回はこんなにも遅いのよ。
    もう、アップデートしちまったよ。2.05だったからはなっからTN-Vは入れられんかったし。

  3. TN-V’s avatar

    自分的にはTN-V良かったんですけどね~
    CTFを色々変えてたらフリーズするテーマが幾つか有って
    最終的にはそれが原因でTN-Vが使えなくなってしまったので次のTN-Vを期待してたのに
    TN-Cは使えるので今はCで我慢してます

  4. 173210’s avatar

    バージョン2.05のタイトルは関数が足りていれば2.06のもので代用できるはずです。
    こうなってくると2.06用の日本版のリリースも重要視する必要が出てきますが…

  5. mayataka’s avatar

    TYLの件では大変お世話になりました。ここで感謝の意をば。
    VHBLの、2.06に上げた人は次善策としてこれを使って下さい、という救済措置ですよね。
    私はプログラミングに関して知識が乏しいのですが、ユーザーモードのexploitの場合は、タイトル毎にそういった「隙間」が存在している、ということなのですかね。
    つまり、例えばバージョンがさらに2.07に引き上げられたと仮定して、その日本版のユーザモードexploitが使えなくなる、という可能性は低いという見方でいいのでしょうか?
    もしそうだとすれば、システムソフトウェアアップデートまでの猶予期間の観点から、次のバージョンアップまで待つというのも一つの案として有用性がありそうな気もします。

  6. mayataka’s avatar

    TN-VでCTFを使用している場合、リカバリーメニューからソニーロゴ画面に当たる部分をスキップするようにすると使えるほとんどの場合フリーズしなくなりますよ。

  7. 名無し’s avatar

    フリーズしてからCTFを外してもゲームをクリックするとフリーズしてしまいゲームが出来ない状態なので何度かインストールし直してみたのですが改善されずメモリーカード自体もフォーマット掛けてみたのですが使えないので已む無くTN-Cに戻した次第です;;

  8. mamosuke’s avatar

    根本的に、今の仕組みを構築された上にストアから購入するゲームを利用する以外の方法がない以上、こうなることは予め分かっていました。

    これがePSPの限界だと思います。
    仮に上手く行く方法があったとしても、同じことを後日繰り返すだけです。

    数年後には、あんなこんなと苦労した時期がVitaにもあったよな、と回顧する時がくるかもしれませんよ。

  9. 173210’s avatar

    おそらく次のバージョンアップでその「隙間」を突くセーブデータを読めないように対策されます。
    それはとても簡単なはずです。

  10. mayataka’s avatar

    ttp://wololo.net/talk/viewtopic.php?f=52&t=31756
    こちらでもThe Z氏の発言の通り、すぐに2.02よりも上のバージョンのkexpoitのリリースがあると思ってはいけないとのご指摘をいただきました。
    TN-Vその他PSPemulateを利用したい場合は2.02でしばらく留まるほかなさそうです。

Reply

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

次のHTML タグと属性が使えます: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong> <img localsrc="" alt="">