さらば「お使いのバージョン9.90」VERSiON.TXT SWiTCHER by Yoti





PSPKingで、Yoti氏が5.50GENでファームウェアのアップデートを実行すると「お使いのPSPのシステムソフトウェアはバージョン9.90です。アップデートする必要はありません。」と表示されアップデートできない状態になるバージョン偽装工作を回避するVERSiON.TXT SWiTCHERをリリースしたことを伝えていました。

CFW 5.50GENをまだ使用しているユーザーに
「どうして6.XXMEや6.XXPROにアップデートしないの?」
と聞くと、返ってきそうな答えのひとつに
「アップデートしようとするとお使いのバージョンは9.90でアップデート必要ないといわれるんだ」
というのがあります。

5.50GENがバージョンを9.90に偽装していることが原因ですが、不用意なアップデートを避けたかった5.50GENが主流の頃ならいざ知らず、現在では余計なお世話的機能です。私の場合は面倒だったのでパンドラバッテリーで一度OFW5.00へ戻してから6.XXにアップデートしていました。

VERSION.TXT Switchは余計なお世話メッセージを表示しないようにversion.txtを入れ替えてくれるHomebrewです。

ダウンロードにはロシア語のフォラームに登録する必要があるため私は見送りました。正確には見送ったというより登録できなかったと言った方が正しいです。
登録に必要な事項にランダムクエスチョンというのがありますが(内容は(1+0)*1の答えを数字ではなく言葉で書けというものです)、質問自体が文字化けするし、ブラウザのエンコード変更してやっと出てくるのはロシア語だし、答えを英語で書いてもgoogle先生に聞いたロシア語で書いてもはねられるしで面倒臭くなって投げ出しました。VERSiON.TXT SWiTCHERなくても必要な時にはパンドラ使えばなんとかなります(笑)

[インストールおよび使用方法]
1) V_SWITCHフォルダをms0(ef0):/PSP/GAME/にコピーする
フォルダ配置は以下のようになる。
PSP
 |-GAME
   |-V_SWITCH
    |-EBOOT.PBP
    |-version1.txt
    |-version2.txt
    |-version3.txt
    |-version4.txt

2) Game => Memory Stick にあるVERSiON.TXT SWiTCHERを起動する

versiontxtswitcher

3) 十字キー左右でversion.txtを選択しXで確定 上下でversion.txtを書き込む場所(sepluginsフォルダかflash0)を選択

試していないので最後のあたりがあやふやですが、version.txtを4つまで用意しておくことができ、それぞれversionN.txt(Nは1から4の数字)にしておく必要があるようです。

Tags: ,

Reply

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です