3.52 ロックマンVHBL修正版 by qwikrazor87

ツイッターで、qwikrazor87氏が日本版の『ロックマン ロックマン』が持つ脆弱性を利用してVitaの最新ファームウェアである3.52のePSP(PSPエミュレータ)でHomebrewを起動するためのHomebrewローダー3.52 VHBLの修正版をリリースしていました。


もともと3.52 ロックマンVHBLは173210氏がexploitを発見して移植していましたが、修正したというよりは独自に移植をしたという感じみたいです。


日本版のロックマン ロックマン向け3.52 VHBLです。動くかどうかは分かりません。ダンプデータくれた@173210氏に感謝。

qwikrazor87のVHBLは何が仕掛けを施したようで、173210氏によると彼のリリースしたバージョンよりもHomebrew起動に対する互換性が向上しているそうです。


じゃあこのVHBLはHomebrew起動への互換性は良くなってるはず。

『ロックマン ロックマン』は通常価格に戻ってはいるもののまだ削除されずに販売が継続されているそうです。3.52 VHBLに興味のある方は試してみてはいかがでしょうか。


シェアする

  • このエントリーをはてなブックマークに追加

フォローする


『3.52 ロックマンVHBL修正版 by qwikrazor87』へのコメント

  1. 名前:173210 投稿日:2015/09/16(水) 12:17:37 ID:0548a78de 返信

    仕掛けはソースコードを見るとよく分かります。以前リークしたものに含まれていたんですが、何故か対策されてなかったようです。突貫工事で作られたものなので、後で私がリファクタリングをしてから現在のHBLにマージするつもりです。

  2. 名前:luckyithizon 投稿日:2015/09/16(水) 21:54:55 ID:7f0657966 返信

    ロックマンVHBL修正版を起動しようとすると
    エラーが起きました。
    (C1-2858-3)
    と出て使えません

  3. 名前:GM2 投稿日:2015/09/17(木) 16:13:31 ID:9a38febae 返信

    同じくPCH-1100モデルでエラーです

  4. 名前:GM2 投稿日:2015/09/17(木) 16:22:24 ID:9a38febae 返信

    It should work now for Mega Man JP 3.52. https://t.co/b6S3jQtsNp source: https://t.co/46kETHZAG5— qwikrazor87 (@qwikrazor87) 2015, 9月 15

  5. 名前:GM2 投稿日:2015/09/17(木) 16:23:07 ID:9a38febae 返信

    ツイートは貼り付け無理でしたのでリンクを
    https://t.co/b6S3jQtsNp
    修正版だそうです(v2)

  6. 名前:初心者 投稿日:2015/09/17(木) 20:49:22 ID:af0097b62 返信

    初心者なのでおしえていただきたいのですが今回公開されたVHBL3.52版で
    スーファミエミュを動かしたいのですがフリーズしたりエラーコードで動きません。
    これはどうしたら解決するのでしょうか?教えていただければと思います。